SMF 2.0.17 Released :: December 30, 2019

Started by Jason, December 31, 2019, 11:33:56 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Jason

Please visit SMF's release post on Dec 30:

https://www.simplemachines.org/community/index.php?topic=571067

It fixes some issues that were discovered with 2.0.16 which was released several days ago.

QuoteDear Members,

Simple Machines has released a new patch to the 2.0.x line of SMF, bringing our latest release version to 2.0.17.

We consider this patch to be of crucial importance, as it includes an important fix for a critical bug that was introduced in SMF 2.0.16.

    Fixes a bug that could cause SMF 2.0.16 to start consuming significant amounts of CPU-resources when the RSS function was used.
    Eliminates some deprecated function warnings when using SSI.php on PHP 7.2+.


Please see the changelog for more information.

Since SMF 2.0.17 is essentially what 2.0.16 was intended to be and 2.0.16 was released only a few days ago, we are including a (slightly updated) version of the SMF 2.0.16 announcement for your convenience:

SMF 2.0.16 contained important security and bug fixes, as well as support for the European Union's General Data Protection Regulation (GDPR) requirements. We recommend updating as soon as possible.

Notable changes in 2.0.16 & 2.0.17

    Support for privacy policy in addition to registration agreement
    GDPR Compliance toggle in Core Features
       Enabling this configures multiple settings and new features to comply with the GDPR, including:
        Requiring members to accept the current privacy policy in order to use the forum
        Asking during registration whether the new member wants to receive announcements via email
        Enabling token-based unsubscribe links in emails so members can unsubscribe without logging in
        Allowing members to download a copy of their profile information
        Adjusting the behaviour of a number of other features in minor ways as necessary
    PHP 7.2 support
    Improved security hashes for the image proxy
    Improved security for the login cookie
    Assorted other security improvements
    Various improvements for both the installer and upgrader

Please see the changelog for more information.


IMPORTANT NOTES:

    If you are using the GDPR Helper mod, you should follow these steps:
        Back up your existing privacy policy text to a file somewhere
        Update the GDPR Helper mod to its latest version
        Uninstall the GDPR Helper mod
        Install the SMF 2.0.16 patch
        Install the SMF 2.0.17 patch

    All users, including the admin, will need to log in again after 2.0.16 has been installed. The admin can then proceed to install 2.0.17.


How to update to 2.0.17

If you are running version 2.0.16, you can update your forum to the latest version by using the package manager. You should see the update notification in the admin panel notifications and in the package manager, which will allow you to download and install the patch seamlessly.  If you do not see the notification about the patch, please run the scheduled task "Fetch Simple Machines files" from the Scheduled Tasks page (Admin > Maintenance > Scheduled Tasks).

If you are still running version 2.0.15, you can first patch to 2.0.16 and then patch to 2.0.17 immediately afterwards. We apologise for the inconvenience.

If you use an older version of SMF, you can upgrade directly to 2.0.17 from whichever version you are currently using by using the "Large Upgrade" package from the Download page. Be aware that using this upgrade method will require you to reinstall any customizations that you have added to your forum, so if you are running a version of the 2.0.x series, it is recommended that you apply the successive patches instead of using the Large Upgrade.

If you are having problems downloading the patch from the admin panel, you can download the patch package from the Package Manager Updates page and install it via the Package Manager, as you would any other mod package.

Please refer to the Online Manual for more details about patching and upgrading.


Language packages for 2.0.16/2.0.17 - Translators wanted!

Adding GDPR support required changes to several of SMF's language files in 2.0.16 (and higher). Updates to SMF's supported language packages will become available as the translations of those changes are completed.

If you can help translate these changes into your language, we would love to hear from you!


Finally, as always, please do not use this topic for support requests. You will receive a much quicker and better response by posting in the 2.0.x Support Board.

Thank you for using SMF!

Regards,
Simple Machines